Sat, 27 Jul 2013

Installing rvm


Keywords: rvm ruby 1.9.3 tmuxinator zsh

In order to upgrade tmuxinator I needed to run Ruby 1.9.3. So I installed rvm as follows:

$ bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer)

and added the following to my .zshrc:

if [[ -e ~/.rvm/scripts/rvm ]] then
    . ~/.rvm/scripts/rvm
    .  ~/.rvm/gems/ruby-1.9.3-p448/gems/tmuxinator-0.6.2/completion/tmuxinator.zsh
fi

then

$ rvm install 1.9.3
$ rvm use 1.9.3 --default
$ gem install tmuxinator

I also had up change my tmuxinator config files:

$ cd ~/.tmuxinator
$ perl -pi.bak -e 's/cli_args/tmux_options/' *.yml
$ perl -pi.bak -e 's/tabs/windows/' *.yml
$ perl -pi.bak -e 's/^project_//' *.yml
$ perl -pi.bak -e 's/-2$/-l -2/' *.yml

The last change there is because with just the "-2" in tmux_options I got the error:

in `tmux_options': undefined method `strip' for -2:Fixnum (NoMethodError)

[/software/ruby] permanent link




September 2017
Sun Mon Tue Wed Thu Fri Sat